Как настроить Mikrotik для обхода блокировок Роскомнадзор.

  1. Настраиваем VPN соединение на микротике до готового или купленного впн сервера. В моем случае купленный FrootVPN. Я использую L2TP соединение без шифрования. Подключаюсь к питерскому серверу.
  2. В IP — Firewall — Mangle помечаем трафик который идет на Dst. Address List = RKN маркером RKN
  3. В IP — Firewall — NAT создаем правило маскарадинга пакетов, которые идут на Dst. Address List = RKN
  4. В IP — Routes создаем статический маршрут. Dst. Address = 0.0.0.0/0, Gateway = l2tp-out-FrootVPN, Routing Mark = RKN. Таким образом все промаркированные пакеты маркером RKN идут в туннель VPN.
  5. Теперь нужно создать список Address List пакеты на который будут маркероваться маркером RKN. Для этого идем на сайт https://antifilter.download/ и качаем список ipsum.lst
    Открываем данный список в Sublime Text и жмем меню Find — Replace. Ищем регулярное выражение (.*) и заменяем его на add address=$1 list=RKN
    Данной командой мы находим IP адрес в строке, запоминаем его и заменяем на строку add address=запомненный_адрес list=RKN. Нажимаем Replace All, Sublime заменяет все найденные вхождения. Нам остается добавить в начало списка строку /ip firewall address-list и в конце удалить лишнюю строку, если она появилась. Получится файл такого вида:
    /ip firewall address-list
    add address=1.32.194.0/24 list=RKN
    add address=1.36.178.0/24 list=RKN
    add address=1.36.236.0/23 list=RKN
    add address=1.163.80.0/24 list=RKN
    add address=1.163.83.0/24 list=RKN
    add address=1.163.85.0/24 list=RKN

Данный файл мы сохраняем с именем rkn.rsc, затем загружаем его в микротик и в терминале выполняем команду import file=rkn.rsc
Ждем пока произойдет создание адресного листа. После успешного создания все заблоченные сайты будут открываться. Есть микротик начнет грузиться и тормозить, можно отключить fasttrack.